Predator 420cc on a 1436 jon boat

User avatar
jmscherrman
Posts: 535
Joined: Mon Oct 21, 2013 8:25 pm
Location: PC, Iowa
Location: Prairie City, IA

Re: Predator 420cc on a 1436 jon boat

Post by jmscherrman »

The motor plate was hitting the transom bracket... we are thinking the transom is at a weird angle. If that's the case is not a big deal because the motor isn't running bad in the position we have it in.

TECshoot
Posts: 146
Joined: Sun Feb 23, 2014 6:15 pm
Location: Hortonville, WI
Location: Wisconsin

Re: Predator 420cc on a 1436 jon boat

Post by TECshoot »

jmscherrman wrote:We are sorting that out this week. We originally had it on the outside of the transom but it wouldn't allow enough height to get the prop out of the water for maneuvering the boat at low speeds.

Any suggestions?
I had this problem when I first got my kit. SPS shortened up the upright arms on the gimble bracket to improve handling. Because of my steep transom angle and the predator engine I was running things weren't working, same problem couldnt get the prop up. After playing with this for three weeks I called Swamp Runner and they swapped my shorter gimble for one with taller arm`s. I run mine with the swivel outside the boat.
1436 Alumacraft Jon-Predator 420
13ft wood duck skiff-Predator 212

User avatar
jmscherrman
Posts: 535
Joined: Mon Oct 21, 2013 8:25 pm
Location: PC, Iowa
Location: Prairie City, IA

Re: Predator 420cc on a 1436 jon boat

Post by jmscherrman »

Can you post a photo of that?

TECshoot
Posts: 146
Joined: Sun Feb 23, 2014 6:15 pm
Location: Hortonville, WI
Location: Wisconsin

Re: Predator 420cc on a 1436 jon boat

Post by TECshoot »

jmscherrman wrote:Can you post a photo of that?
What exactly do you want to see a photo of?
1436 Alumacraft Jon-Predator 420
13ft wood duck skiff-Predator 212

User avatar
jmscherrman
Posts: 535
Joined: Mon Oct 21, 2013 8:25 pm
Location: PC, Iowa
Location: Prairie City, IA

Re: Predator 420cc on a 1436 jon boat

Post by jmscherrman »

The gimble with the taller arms

User avatar
JD
Posts: 940
Joined: Tue Jan 17, 2012 3:19 pm
Location:
Location: Palmetto, FL

Re: Predator 420cc on a 1436 jon boat

Post by JD »

Yes, we discovered that some Alumacrafts and older jonboats have a steeper transom angle than the usual 14 degrees. We're raising the gimble arms slightly on future Medium Swamp Runners in order to accommodate these boats.
Psalm 55:7 - Lo, then would I wander far off, and remain in the wilderness.

User avatar
jmscherrman
Posts: 535
Joined: Mon Oct 21, 2013 8:25 pm
Location: PC, Iowa
Location: Prairie City, IA

Re: Predator 420cc on a 1436 jon boat

Post by jmscherrman »

Interesting, all the more reason to go with a newer boat when I upgrade.

User avatar
AJCsurf
Posts: 218
Joined: Fri Aug 17, 2012 9:51 pm
Location:
Location: Central Coast, California

Re: Predator 420cc on a 1436 jon boat

Post by AJCsurf »

JD wrote:Yes, we discovered that some Alumacrafts and older jonboats have a steeper transom angle than the usual 14 degrees. We're raising the gimble arms slightly on future Medium Swamp Runners in order to accommodate these boats.
The new alumacrafts have this issue too, as in brand new?

TECshoot
Posts: 146
Joined: Sun Feb 23, 2014 6:15 pm
Location: Hortonville, WI
Location: Wisconsin

Re: Predator 420cc on a 1436 jon boat

Post by TECshoot »

AJCsurf wrote:
JD wrote:Yes, we discovered that some Alumacrafts and older jonboats have a steeper transom angle than the usual 14 degrees. We're raising the gimble arms slightly on future Medium Swamp Runners in order to accommodate these boats.
The new alumacrafts have this issue too, as in brand new?
Yes, I have a new Alumacraft 1436. New but I think It is a 2013 model. I dont think they make a 1436 "light" model for 2014 like mine is.
1436 Alumacraft Jon-Predator 420
13ft wood duck skiff-Predator 212

User avatar
PJB
Posts: 545
Joined: Thu Mar 13, 2014 12:51 pm
Location: Middle-Diddle Georgia
Location: Middle Georgia

Re: Predator 420cc on a 1436 jon boat

Post by PJB »

I have a Lowe that presented the same issue. I had to flip mine around. However, it seems to run fine, but I am running a narrow hull.

Post Reply